$re = '/^(?:\b\w+[^\w\r\n]*){5,}$/m';
$str = 'This is a test
This is a test that comes up with somethig thats different ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);