#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:[A-Z]:|\\|(?:\.{1,2}[\/\\])+)[\w+\\\s_\(\)\/]+(?:\.\w+)*"
Local $sString = " # URLs" & @CRLF & _
" "https://www.google.com"," & @CRLF & _
" "www.google.com"," & @CRLF & _
" "www.google.com www.example.com"," & @CRLF & _
"" & @CRLF & _
" # Paths" & @CRLF & _
" "/foo/bar"," & @CRLF & _
" "/foo/bar.txt"," & @CRLF & _
" "../foo/bar/"," & @CRLF & _
" "../../foo/bar/"," & @CRLF & _
" "./foo/bar/"," & @CRLF & _
" "./foo/bar.txt"," & @CRLF & _
" "\\foo\\bar.txt"," & @CRLF & _
" "C:\\foo\\bar.txt"," & @CRLF & _
" "C:/foo/bar.txt"," & @CRLF & _
"" & @CRLF & _
" # Mixed" & @CRLF & _
" "https://www.google.com ./foo/bar.txt"," & @CRLF & _
" "[markdown](./foo/bar.txt)"," & @CRLF & _
" "Lorem ipsum ./foo_bar/baz.txt Lorem ipsum","
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")