use strict;
my $str = ' # URLs
"https://www.google.com",
"www.google.com",
"www.google.com www.example.com",
# Paths
"/foo/bar",
"/foo/bar.txt",
"../foo/bar/",
"../../foo/bar/",
"./foo/bar/",
"./foo/bar.txt",
"\\\\foo\\\\bar.txt",
"C:\\\\foo\\\\bar.txt",
"C:/foo/bar.txt",
# Mixed
"https://www.google.com ./foo/bar.txt",
"[markdown](./foo/bar.txt)",
"Lorem ipsum ./foo_bar/baz.txt Lorem ipsum",';
my $regex = qr/(?:[A-Z]:|\\|(?:\.{1,2}[\/\\])+)[\w+\\\s_\(\)\/]+(?:\.\w+)*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}