// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:[A-Z]:|\\|(?:\.{1,2}[\/\\])+)[\w+\\\s_\(\)\/]+(?:\.\w+)*").unwrap();
let string = " # URLs
\"https://www.google.com\",
\"www.google.com\",
\"www.google.com www.example.com\",
# Paths
\"/foo/bar\",
\"/foo/bar.txt\",
\"../foo/bar/\",
\"../../foo/bar/\",
\"./foo/bar/\",
\"./foo/bar.txt\",
\"\\\\foo\\\\bar.txt\",
\"C:\\\\foo\\\\bar.txt\",
\"C:/foo/bar.txt\",
# Mixed
\"https://www.google.com ./foo/bar.txt\",
\"[markdown](./foo/bar.txt)\",
\"Lorem ipsum ./foo_bar/baz.txt Lorem ipsum\",";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}