use strict;
my $str = '25.0296.110.0003087.20 18
25-0296-110-0003087-20
25/0296/110/0003087/20
25.0296-110/0003087/20
250296110000308720
250296110308720
';
my $regex = qr/(\d{2})([\.\/-]?)(\d{4})([\.\/-]?)(\d{3})([\.\/-])?(\d{1,7})([\.\/-]?)(\d{2})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}