import Foundation
let pattern = #"(\d{2})([\.\/-]?)(\d{4})([\.\/-]?)(\d{3})([\.\/-])?(\d{1,7})([\.\/-]?)(\d{2})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
25.0296.110.0003087.20 18
25-0296-110-0003087-20
25/0296/110/0003087/20
25.0296-110/0003087/20
250296110000308720
250296110308720
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)