re = /(?:^\s*func\s(display\w*)\(\)$)/m
str = 'protocol SceneDisplayView {
func displayEmailScreen()
func displayPasswordScreen()
func displayNameScreen()
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end