import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^(?:(?:(?:31(?:(?:([-.\\/])(?:0?[13578]|1[02])\\2)|(?:([-.\\/ ])(?:Jan|JAN|Mar|MAR|May|MAY|Jul|JUL|Aug|AUG|Oct|OCT|Dec|DEC)\\3)))|(?:(?:29|30)(?:(?:([-.\\/])(?:0?[13-9]|1[0-2])\\4)|(?:([-.\\/ ])(?:Jan|JAN|Mar|MAR|Apr|APR|May|MAY|Jun|JUN|Jul|JUL|Aug|AUG|Sep|SEP|Oct|OCT|Nov|NOV|Dec|DEC)\\5))))(?:(?:1[6-9]|[2-9]\\d)?\\d{2}))$|^(?:29(?:(?:([-.\\/])(?:0?2)\\6)|(?:([-.\\/ ])(?:Feb|FEB)\\7))(?:(?:1[6-9]|[2-9]\\d)?(?:0[48]|[2468][048]|[13579][26])|(?:(?:16|[2468][048]|[3579][26])00)))$|^(?:(?:0?[1-9]|1\\d|2[0-8])(?:(?:([-.\\/])(?:(?:0?[1-9]|(?:1[0-2])))\\8)|(?:([-.\\/ ])(?:Jan|JAN|Feb|FEB|Mar|MAR|May|MAY|Jul|JUL|Aug|AUG|Oct|OCT|Dec|DEC)\\9))(?:(?:1[6-9]|[2-9]\\d)?\\d{2}))$)";
final String string = "01/01/2000\n"
+ "31/01/2000\n"
+ "32/01/2000\n\n"
+ "01/1/2000\n"
+ "01/1/01\n\n"
+ "29/02/2000\n"
+ "28/02/2001\n"
+ "29/02/2001\n\n"
+ "30/04/2000\n"
+ "31/04/2000\n"
+ "31/07/2000\n"
+ "31/08/2000\n"
+ "31/09/2000\n\n"
+ "01/12/2000\n"
+ "01/15/2000\n\n"
+ "29-02-2020\n"
+ "29-02-2024\n"
+ "29-02-2000\n"
+ "29-02-2100\n"
+ "29-02-2400\n\n"
+ "29-0,-11\n\n"
+ "01/Mar/2020\n"
+ "29/Mar/2020\n"
+ "31 Jul 2020\n"
+ "30 Apr 2020\n"
+ "29 Feb 2020\n"
+ "29 May 2100\n"
+ "8 Aug 2020\n"
+ "26 OCT 2024\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}