import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=(^|\\p{Zs}|\\b)[vozuskia])(?!\\u00A0)\\p{Zs}";
final String string = "Dva žáci testovali odskok nového tenisového míčku. Pustili ho z výšky 2,54 metru na hladký, pevný vodorovný povrch a zjistili, že se odrazí do dvou třetin (23) původní výšky.";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}