$re = '/(?<=(^|\p{Zs}|\b)[vozuskia])(?!\u00A0)\p{Zs}/m';
$str = 'Dva žáci testovali odskok nového tenisového míčku. Pustili ho z výšky 2,54 metru na hladký, pevný vodorovný povrch a zjistili, že se odrazí do dvou třetin (23) původní výšky.';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;