$re = '/^([a-z0-9]+(?:[.!#$%&\'*+\\\\/=?^_`{|}~-][a-z0-9]+)*)@([a-z0-9]+(?:[.-][a-z0-9]+)*\.[a-z]{2,})$/';
$str = 's!s!f@n.eu';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);