$re = '/\b(([A-Z])\2{0,2}(?:100|[1-9]\d?))\b/m';
$str = 'A1 AA2 AAA3 B100 CC7 ABC1234
A12 AA21 AAA36 B57 CC76 ABC1234
UVW1 ABC2 AAAA4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);