const regex = /^(?<pool>(?<letter>[A-Z])\k<letter>{0,2})(?<number>(100|[1-9]\d?))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<pool>(?<letter>[A-Z])\\k<letter>{0,2})(?<number>(100|[1-9]\\d?))$', 'gm')
const str = `A1
AA2
AAA3
B100
CC7
ABC1234
A12
AA21
AAA36
B57
CC76
ABC1234
UVW1
ABC2
AAAA4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}