# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\/\*\N*?\*\/\K|\/\*.*?\*\///gs;t' <<< "/* comment */ not a comment /* another comment */
/* delete this *
/* multiline *
/* comment */
/*************
/* and this *
/************/
The End"