use strict;
my $str = '/* comment */ not a comment /* another comment */
/* delete this *
/* multiline *
/* comment */
/*************
/* and this *
/************/
The End';
my $regex = qr~/\*\N*?\*/\K|/\*.*?\*/~sp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";