re = /^(\/[a-z0–9\/_-]*(?<!\/))([^\/]*)$/m
str = '/news
/news?param1=value1
/news#anchor?param1=value1
/not_me/
'
subst = '$1/$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result