# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.*?),\s+(.*?),(.*?)\."
test_str = ("The George Washington University, Washington, DC, USA.\n"
"Department of Pathology, University of Oklahoma Health Sciences Center, Oklahoma City, USA. adekunle-adesina@ouhsc.edu\n"
"Department of Animal Sciences and Division of Nutritional Sciences, University of Illinois, Urbana, IL 61801, USA.\n"
"Department of Radiotherapy, Centre of Oncology-Maria Sklodowska-Curie Memorial Institute, Warsaw, Poland. gardas@cmkp.edu.pl\n"
"Eastern New York Occupational and Environmental Health Center, Mount Sinai School of Medicine, Department of Community Medicine, Albany, NY, USA. johanni2@crisny.org")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.