$re = '/^([A-Z]+)(?:,([A-Z]+))?(?:,([A-Z]+))?$/m';
$str = 'HELLO,LITTLE,WORLD
HELLO,WORLD
HELLO';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);