# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?![^:\s]+:)/Line:/mg;t' <<< "1 : A
2 : B
3 : C
1
2
3
1:A
11:A"