import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+\\.\\d+?$";
final String string = "TP1 BCArc 156.2\n"
+ "TP2 Max: of output here 0.01\n"
+ "TP3 some:other example 1 here 30.70\n"
+ "TP1 BCArc 30\n"
+ "TP2 Max: of output here 2.22";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}