import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.{0,72})";
final String string = "Sujeito a IPI (sem mensagem) MERCARDORIA COLETADA NO ARMAZEM GERAL CENTRO DE DISTRIBUICAO E LOGISTICA SENHORA DA PENHA S.A - CNPJ: 04.077.240/0003-07 - I.E: 255.382.148.113 RUA DOS TUCANOS,630 - GALPAO14 BAIRRO: SITIO GUAREHY - CARAPICUIBA / SP CEP: 063...";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}