re = /(StartOrder,(\d{0,}).*?deliver.)/m
str = 'StartOrder,1,SupplierName,
zzzzzzzzzz
EndOrder,5,booked as soon as possible to deliver1.
StartOrder,6,SupplierName,
aaaaaaaaaa
EndOrder,10,booked as soon as possible to deliver.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end