// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)(StartOrder,(\d{0,}).*?deliver.)").unwrap();
let string = "StartOrder,1,SupplierName,
zzzzzzzzzz
EndOrder,5,booked as soon as possible to deliver1.
StartOrder,6,SupplierName,
aaaaaaaaaa
EndOrder,10,booked as soon as possible to deliver.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}