package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d(,|\d)*`)
var str = `123456,54,435,3246,4365243,623,46,432,2,43,5243652,43652436,234,65,2436,32465,234,6523465,234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}