const regex = /\b\d+\)\h*\K.*?(?=\b\d+\)|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d+\\)\\h*\\K.*?(?=\\b\\d+\\)|$)', 'gm')
const str = `1) some text 2) some more text 3) even more text, with commas and such 4) bye!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}