Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?<=START)(?s)(.*?)(?=Closing)
/
g
Input 1
1
New
more useless gibberish at the begininng... separated by new lines... START Fund Class Fund Number Fund Currency XYZ XYZ XYZ USD bunch of text with lots of newlines in between... Closing 11.11 1,111.11 111,111.11 more useless gibberish between the groups... separated by new lines... START Fund Class Fund Number Fund Currency XYZ XYZ XYZ USD The word START appears in the middle sometimes multiple times, but it's fine bunch of text with lots of newlines in between... Closing 22.22 2,222.22 222,222.22 more useless gibberish at the end... separated by new lines...