using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?![^\W_\d]+$)[^\W_]{9,}$";
string input = @"12345678987654567
jhsjd4567hsqdgqsgh456786576567kj
9l8j9n9k0n9n8n
loremipsum
a1
12567";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}