re = /^(?![^\W_\d]+$)[^\W_]{9,}$/m
str = '12345678987654567
jhsjd4567hsqdgqsgh456786576567kj
9l8j9n9k0n9n8n
loremipsum
a1
12567'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end