using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^.*\\src\\)?(\w+)(?!\w*$)|(\W)|(\w+)$";
string input = @"c:\workspace\src\chrome\browser\ui\webui\settings\about_handler.h";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}