re = /(?:^.*\\src\\)?(\w+)(?!\w*$)|(\W)|(\w+)$/m
str = 'c:\\workspace\\src\\chrome\\browser\\ui\\webui\\settings\\about_handler.h'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end