# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=[a-z])[A-Z]|[A-Z](?=[^A-Z])/_\g<0>/gm;t' <<< "'someWorkingTestingPhrase', 'shortMINEPasscode'"