#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=[a-z])[A-Z]|[A-Z](?=[^A-Z])"
Local $sString = "'someWorkingTestingPhrase', 'shortMINEPasscode'"
Local $sSubst = "_\g<0>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)