use strict;
my $str = '\'someWorkingTestingPhrase\', \'shortMINEPasscode\'';
my $regex = qr/(?<=[a-z])[A-Z]|[A-Z](?=[^A-Z])/mp;
my $subst = '_\\g<0>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";