#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<<<<<<<(?:\r?\n|.)*=======(?:\r?\n|.)*>>>>>>>.*\r?\n"
Local $sString = "/**********************************" & @CRLF & _
"!&DOC-TECHNIQUE ! src/cmm/bacchus/b" & @CRLF & _
"!===============!==================" & @CRLF & _
"!&Fiche Du ! S.! Operateu" & @CRLF & _
"!__________________!___!___________" & @CRLF & _
"<<<<<<< HEAD" & @CRLF & _
"=======" & @CRLF & _
"! 2017-07-13! !Michèle ROY" & @CRLF & _
">>>>>>> 157443 - DRM-CIEL" & @CRLF & _
"!__________________________________" & @CRLF & _
"! " & @CRLF & _
"!__________________________________" & @CRLF & _
"&End " & @CRLF & _
"***********************************" & @CRLF & _
"" & @CRLF & _
"{d-brokmini.i}" & @CRLF & _
"{bt-expciel.i }" & @CRLF & _
"{maquette.i }" & @CRLF & _
"{tabsoc.i }" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")