package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mU)^\p{L}\w{2,23}\p{Alnum}$`)
var str = `_notthis
nothis_
yes_123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}