$re = '/((?:\"[^"]*)\s*\")|((?:\'[^\']*)\s*\')|((?:\`[^`]*)\s*\`)|((?:\b|\s){1}const\s{1})|((?:\b|\s){1}function\s{1})|((?:\b|\s){1}let\s{1})|(?:\/\/.*$)|(?:\/\*+(?:.|\s)*\*\/)|\s*/im';
$str = 'function myFunction() {
let carName = "Volvo";
// code here CAN use carName
const test = \'string with "quoted substring"\'; let airplane = \'fly\'
("and another string th\'\' as\' asd \'ere")
labelForStrings: {
`t\'is a "string"`
}
}
/*asd *****
* 324 @*l;;?\\\\\\
* multiline comment
*** /
*/';
$subst = "$1$2$3$4$5$6";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;