import re
regex = re.compile(r"(?:\$[\d+,]{,100})", flags=re.MULTILINE)
test_str = ("Ваша ассоциация наняла рабочего Стэнфорд Флеминг за $208,000,000. Основным соперником была ассоциация Путь со ставкой $195,440,000.\n\n\n\n"
"Следующие игроки приняли участие в аукционе:\n\n"
"DikoBrazzers: $28,450,000\n\n"
"рус73: $27,880,000\n\n"
"TANK1515: $20,110,000\n\n"
"Крысолов: $20,000,000\n\n"
"Валентинович 55: $19,860,000\n\n"
"Slepoy 16ru: $15,000,000\n\n"
"Виктор 74: $13,680,000\n\n"
"корефанец: $10,850,000\n\n"
"Папа Djo: $10,210,000\n\n"
"Кадима: $10,020,000\n\n"
"Aleks Mechanic: $9,410,000\n\n"
"пожик47: $9,300,000\n\n"
"super_skif: $7,590,000\n\n"
"Лoки: $5,640,000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")