#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=#00FF|#FF00)[A-Fa-f0-9]{2}|[A-Fa-f0-9]{2}(?=00FF|FF00)|(?<=#00)[A-Fa-f0-9]{2}(?=FF)|(?<=#FF)[A-Fa-f0-9]{2}(?=00)"
Local $sString = "Correct cases:" & @CRLF & _
"#FF0012" & @CRLF & _
"#00FFAB" & @CRLF & _
"#0034FF" & @CRLF & _
"#CD00FF" & @CRLF & _
"#56FF00" & @CRLF & _
"#FF7800" & @CRLF & _
"" & @CRLF & _
"Incorrect cases:" & @CRLF & _
"#0000AA" & @CRLF & _
"#FFFFBB" & @CRLF & _
"#00CC00" & @CRLF & _
"#FFDDFF" & @CRLF & _
"#EE0000" & @CRLF & _
"#FFFFFF"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")