#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(https?:\/\/)?(www\.)?((discordapp\.com/invite)|(discord\.gg))\/(\w+)"
Local $sString = "https://www.discord.gg/lmao" & @CRLF & _
"www.discord.gg/lmao" & @CRLF & _
"" & @CRLF & _
"https://discord.gg/lmao" & @CRLF & _
"http://discord.gg/lmao" & @CRLF & _
"www.discord.gg/lmao" & @CRLF & _
"discord.gg/lmao" & @CRLF & _
"https://discordapp.com/invite/lmao" & @CRLF & _
"http://discordapp.com/invite/lmao" & @CRLF & _
"discordapp.com/invite/lmao" & @CRLF & _
"" & @CRLF & _
"discordapp.gg/lmao"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")