using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/\/)?(www\.)?((discordapp\.com/invite)|(discord\.gg))\/(\w+)";
string input = @"https://www.discord.gg/lmao
www.discord.gg/lmao
https://discord.gg/lmao
http://discord.gg/lmao
www.discord.gg/lmao
discord.gg/lmao
https://discordapp.com/invite/lmao
http://discordapp.com/invite/lmao
discordapp.com/invite/lmao
discordapp.gg/lmao";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}