#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=aba|a$)(?:a(b+)(?=a\1ba|a$))*a$"
Local $sString = "a" & @CRLF & _
"aba" & @CRLF & _
"ababba" & @CRLF & _
"ababbabbba" & @CRLF & _
"ababbabbbabbbba" & @CRLF & _
"ababbabbbabbbbabbbbba" & @CRLF & _
"" & @CRLF & _
"abba" & @CRLF & _
"abbba" & @CRLF & _
"aa" & @CRLF & _
"abbaa" & @CRLF & _
"aabb" & @CRLF & _
"abababa" & @CRLF & _
"ababbba" & @CRLF & _
"abbaba" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")