using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=aba|a$)(?:a(b+)(?=a\1ba|a$))*a$";
string input = @"a
aba
ababba
ababbabbba
ababbabbbabbbba
ababbabbbabbbbabbbbba
abba
abbba
aa
abbaa
aabb
abababa
ababbba
abbaba
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}