re = /(?<=[\s,.])'.*?'(?=[\s,.])/m
str = 'John went out for a walk. He met Mrs. Edwards and said, \'Hello Mam how are you doing today?\'. She replied \'I\'m fine. How are you?\' '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end