#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*function\s+(?:(?:\[((?:\s*(?:\w+[\w0-9]*)\s*,?)+)\]|(\w+[\w0-9]*))\s*=)?[\s.]*(\w+[\w0-9]*)\s*(?:\(([^)]*)\))?"
Local $sString = "function loss = conductionLo7ss (self, Irms, m, DPF)" & @CRLF & _
"function [loss, arg2] = conductionLoss (self, Irms, m, DPF)" & @CRLF & _
"function loss = gf (self, Irms, m, DPF)" & @CRLF & _
"" & @CRLF & _
"function loss = gf(self, Irms, m, DPF)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")