package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\$(?<gross>\d+)\s+\$(?<earnings>\d+)\s+\$(?<pension>\d+)\s+\$(?<refund>\d+)\s+\$(?<garnish>\d+)\s+\$(?<taxes>\d+)\s+\$(?<unk>\d+)\s+\$(?<net>\d+)\s+\$(?<cummTaxes>\d+)202\d{5}.+\$(?<balance>[\d,]+)`)
var str = `[0120168115100180 $231 $30 $0 $0 $0 $23 $53 $208 $2320200616 ******@*****.*** $8,778 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}