#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\w+)\(([^()]+)\)"
Local $sString = "sin(10+sin(sin(90+sin(sin(sin(10))))))+cos(10)+tan(100.00)" & @CRLF & _
"sin(10+sin(sin(90+sin(sin(-0.5440211108893698)))))+-0.8390715290764524+-0.5872139151569291"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")