using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)\(([^()]+)\)";
string input = @"sin(10+sin(sin(90+sin(sin(sin(10))))))+cos(10)+tan(100.00)
sin(10+sin(sin(90+sin(sin(-0.5440211108893698)))))+-0.8390715290764524+-0.5872139151569291";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}