Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
"
(\w+)\(([^()]+)\)
"
gm
Test String
New
sin(10+sin(sin(90+sin(sin(sin(10))))))+cos(10)+tan(100.00) sin(10+sin(sin(90+sin(sin(-0.5440211108893698)))))+-0.8390715290764524+-0.5872139151569291