#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(^|\s*)(!?\/\/)[^\n]+\s*"
Local $sString = " // [created|updated|readed|deleted]" & @CRLF & _
"" & @CRLF & _
"textplain" & @CRLF & _
"other-text" & @CRLF & _
"" & @CRLF & _
"// Other comment" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)