const regex = new RegExp('(https?://)?(www\\.)?(\\S+)(\\.[^\\s\\/]+)(/\\S*)?', 'mg')
const str = `https://www.google.com
http://coreyms.com
https://www.youtube.com/watch?v=sa-TUpSx1JA
https://www.nasa.gov
www.desmos.com
pastebin.com/s8fh3HAs
https://www.regex101.com/
www.translate.google.com/
https://roblox.com/home
chat.openai.com/?model=text-davinci-002-render-sha
https://www.amazon.com/
agar.io/#ffa`;
const subst = `$3$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);